1
Vraag
2
Reacties
deltabert

Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

IP thermostaat via Vodafone 4G

IP thermostaat via Vodafone 4G

Hallo,

Ik heb een gelijksoortige vraag als het topic IP-camera-via-Vodafone-4G:

https://community.vodafone.nl/t5/Diensten/IP-camera-via-Vodafone-4G/m-p/474#M410

Het betreft een verenigings gebouw zonder Internet verbinding maar waar een wifi thermostaat op afstand bediend en ingesteld moet kunnen worden.

Hiervoor heb ik een TP-Link MR6400 4G router aangeschaft maar op de WAN Interface van deze router krijg ik alleen een Private IP@.

Ik kan dus niet vanuit Internet de router benaderen, alleen als ik in hetzelfde IP subnet zit.

Het heeft te maken met  het gebruik van CGNAL door de ISP's.

 

Maar weet iemand hiervoor een oplossing? 

Bovenstaande thread is helaas gesloten maar ik zou graag willen weten of de OP @Saud of iemand anders hier een oplossing voor heeft.

Oplossing

Geaccepteerde oplossingen
deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Het is inmiddels opgelost. Dat was 3 weken geleden; helaas niet eerder toe gekomen om dit te melden.
Na vele helpdesk medewerkers gesproken te hebben heeft de laatste een ticket aangemaakt voor een Vodafone technicus die de open.vodafone.com als APN aan de prepaid SIM card moest koppelen. 
Dat duurde 10 werkdagen, waarna ik, pas na zelf opnieuw Vodafone Helpdesk te bellen, hoorde dat hij dit niet voor pre-paid SIM cards mocht doen.

Opnieuw met Vodafone gebeld en de goedkoopste abonnement oplossing gekozen (korting omdat een van d eleden een Ziggo abonnement heeft).

Nu werkt de oplossing en we kunnen de thermostaat remote bedienen met de bijbehorende App.

 

Ik wil speciaal @Saud bedanken voor het uitvoerig meedenken met dit traject.

Bekijk in context

22 Reacties 22
Energieboy
Expert
Expert
  • 11698Posts
  • 3464Oplossingen
  • 3080Likes

Hoi @deltabert 
Welkom op de klanten helpen klanten Community van Vodafone. 

Laten we deze topic aanhouden voor het juiste antwoord. Ik kan je hiermee niet helpen, misschien dat iemand van Vodafone je hiermee kan helpen. 

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Dag @deltabert,  als je een werkende data-simkaart hebt geplaatst, dan moet je in de WAN interface een extern IP adres krijgen van Vodafone. En als dat niet zo is, dan zouden je internetinstellingen niet juist kunnen zijn in het modem. Je moet een APN kiezen (meestal live.vodafone.com) en daarmee hoor je een extern IP adres te krijgen en dus ook internet. Maar daarmee ben je er nog niet, want je wilt van buitenaf via je modem bij die wifi thermostaat terecht komen. Daarvoor moet je een communicatiepoort kiezen in de thermostaat en die poort moet in je modem open zetten om communicatie van buitenaf door te sturen naar je thermostaat. Ook moet je instellingen in het modem maken zodat het modem weet naar welk wifi-apparaat die informatieaanvraag moet worden doorgestuurd. Ik zeg het een beetje simpel, maar is er nog wel wat in te stellen in het modem. Vervolgens moet Vodafone meewerken om de poort die jij hebt gekozen ook werkelijk open te zetten, zodat je van buitenaf via die poort binnenkomt in je modem en door het modem wordt doorgestuurd naar de thermostaat. En dan ben je er nog niet. Om van buitenaf in je modem te komen, gebruik je normaal het externe IP adres. Zo heb je thuis een extern IP adres van je provider gekregen en daarmee kun je van buitenaf in je thuismodem komen. In de meeste gevallen houd je thuis een vast IP adres dat maar zelden verandert. Bij IP adressen van mobiele providers is dat anders: die veranderen voortdurend en daarom moet je met een naamserver werken, kortweg DDNS. Op die manier kun je je modem in het clubhuis altijd vinden, ongeacht het IP adres dat vodafone eraan heeft gegeven. Er is dus nog wel wat te regelen en in te stellen, maar als het werkt is het geweldig. Ik heb nog dagelijks veel plezier van mijn camera op afstand via 4G. 

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Hallo @Saud Hartelijk dank voor je uitgebreide antwoord. Het is voor mij heel duidelijk.

Mijn plan was om, wanneer ik een Public-IP@ aan de router WAN poort heb, om dan DDNS met no-ip.com te gebruiken als name resolution.  Verder wilde ik proberen om met port forwarding verschillende ports te gebruiken voor Internet en LAN.
Het modem is een TP-Link MR6400 en de thermostaat is een Plugwise Anna. Modem ondersteunt Port Forwarding en DDNS.


Het enige mogelijke probleem hierbij is dat ik waarschijnlijk niet de port in de thermostaat kan veranderen.

Dus als deze op port 80 luistert, dan heb ik alsnog een probleem als ik dat niet kan veranderen.

Maar tot nu toe heb ik met Sim Cards alleen maar een Private-IP@ op de wan poort van de router gekregen. 
(Ik heb Sim Cards van 3 verschillende ISP's geprobeerd) 

 

Ik begrijp dat het jou is gelukt met Vodafone om toegang tot jouw camera te regelen?
Heb je enig idee wie ik bij Vodafone hiervoor kan benaderen? Ik heb nog geen Vodafone Sim Card. maar zoek dus een, liefst prepaid, Data Sim Card met weinig data, want ik verwacht niet veel verkeer met een thermostaat.

 

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Klinkt goed wat je van plan bent. Ik gebruik ook een no-ip DDNS. Dat werkt al jaren goed en is gratis, al moet je wel elke maand even bevestigen dat je hem wilt blijven gebruiken. Wil je dat niet elke maand hoeven doen, dan kun je voor een paar euro ook een betaalde service afnemen. Poort 80 hoeft geen probleem te zijn, zolang je je modem niet van buitenaf wilt benaderen. Als je de toegang tot het modem uitzet, dan kun je poort 80 door routeren via Port Forwarding naar je thermostaat.

Als jij nog steeds geen IP adres van je provider krijgt, dan is er toch nog iets niet goed ingesteld denk ik. Kijk eens naar bijgaand print screentje van de TP-link MR200 een mifi 4G modem waar ik een camera aan heb hangen. In dit geval zit er een KPN datakaart in. Je ziet in het vak internet het IP adres dat nu begint met  188. etc. Terwijl je in het vak LAN het interne IP adres ziet. Zo zou het er ongeveer uit moeten zien, maar ik heb het idee dat je dat prima begrijpt. Ik heb inderdaad met de technische helpdesk van Vodafone contact gehad en zij hebben de koppeling gemaakt tussen een de open APN  (was de enige APN die het mogelijk maakte om het modem van buitenaf te benaderen) en om een poort naar wens open te zetten. Je kunt die hele procedure teruglezen in mijn topic:

https://community.vodafone.nl/t5/Diensten/IP-camera-via-Vodafone-4G/m-p/474#M410

Ik denk dat jij dezelfde weg zou moeten volgen.

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Hallo @Saud  ja via de thread van de link di je stuurde was ik op jouw camera/4G probleem gestuit. In de thread staan twee linkjes naar Facebook en Twitter. Maar dat lijken algemene Vodafone kanalen te zijn, niet een specifieke technische hulp….  Heb je misschien een naam of alias van de technische ondersteuning die jou destijds heeft geholpen?

Iemand die de APN ook kan open zetten.

 

Zo niet dan waag ik het er op en ga ik m’n verhaal daar stellen. 

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Hallo @Saud ik heb een vraag naar ondersteuning hiervoor op Facebook gezet (link van jou).  En de vraag ook maar in de messager geplaatst.    Afwachten op reactie. 

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

@Saud Ik zag dat jij in je TP-Link MR200 router een KPN Data Sim kaart hebt. Ik zit bij KPN/Xs4all en heb ook een data sim kaart van KPN gekregen voor m'n (simpele) Huawei Mifi voor de vakantie.
Die kaart heb ik ook geprobeerd in de MR6400 router, maar ik krijg hier van KPN geen Public IP@. Zie het plaatje.

Hoe ben jij bij de KPN Sim Card aan een Public IP@ gekomen?
Of ben ik misscien iets vergeten bij de configuratie...

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Je hebt gewoon een werkende internetverbinding zie ik aan het gele vinkje en het IP adres dat begint met 10.212 dat is het IP adres dat je hebt gekregen van KPN. Als jij je computer verbindt met dit modem, dan moet je zo het internet op kunnen via je KPN sim card. Dit zijn echter dynamische IP adressen; als jij je modem uitzet en opnieuw aanzet, dan krijg je een heel ander IP adres toegewezen. Als jij dus van buitenaf je modem wilt vinden met de thermostaat, moet je met DDNS werken, je weet immers niet welk dynamisch IP adres jouw modem toegewezen krijgt. Dat moet je dus eerst regelen bij b.v. no-ip.com, dan die instellingen in het modem zetten en NAT instellingen maken in de modem om binnenkomend verkeer op poort 80 door te sturen naar je thermostaat met het interne IP adres 192.168.1. ???? . Bij de TP-Link routers vind je dat instellingenscherm onder "NAT Forwarding" en dan "virtual servers". Dat ziet er dan zo'n beetje uit als bijgaand plaatje, al heb ik bij mijn camera poort 8080 gebruikt voor de communicatie. Als jij de poort in de thermostaat niet kunt kiezen, moet je poort 80 aanhouden. Alle instellingen in het modem zouden dan goed moeten staan. Alleen moet je dan bij KPN of Vodafone (afhankelijk van welke kaart er in het modem zit) voor elkaar krijgen dat ze poort 80 open zetten, zodat je via de naamserver ook echt bij je modem binnen kan komen. Mobiele providers houden al die poorten vaak standaard dicht, om te voorkomen dat er enorm veel data gebruikt wordt. Eigenlijk is dat een beveiligingskwestie. Als je bij vodafone een dataverbinding hebt, dan gebeurt dat meestal via live.vodafone.com. Met die APN zit je eigenlijk veilig achter de NAT van je provider, heb je dus geen echt openbaar IP adres en kan je modem niet van buitenaf worden benaderd. Kies je voor open.vodafone.com dan krijg je een openbaar IP adres dat iedereen van buiten kan benaderen. Je mist dus de bescherming van hun NAT. Als je zelf in je modem en de thermostaat de veiligheid goed regelt met goede wachtwoorden en zo is er niet zoveel aan de hand. Dit is immers alleen maar een modem waaraan een wifi thermostaat is gekoppeld. Volgens mij werkt dat bij KPN eigenlijk direct toen ik hun open APN advancedinternet koos. Met een vodafone kaart kies je dan voor open.vodafone.com. Dat kiezen van een APN doe je door een profiel aan te maken. Hoe je dat doet bij jouw modem, vind je hier:  https://www.tp-link.com/nl/support/faq/1663/   Probeer het maar eens.

 

 

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Hallo @Saud ,

quote:

     Als jij dus van buitenaf je modem wilt vinden met de thermostaat, moet je met DDNS werken, je weet
     immers niet welk dynamisch IP adres jouw modem toegewezen krijgt.

endquote:

 

Dit is nu juist het probleem!   IP@ 10.212.x.x.  Is een Private-IP@ en dat kun je niet gebruiken vanaf Internet (reserved address range).
(Bv met m’n telefoon, met een andere provider kan ik de router ook niet bereiken.)

 

Deze KPN Sim card werkt dus niet zonder aanpassingen. En in de instelling voor APN kan ik niets veranderen.
Dat veld is licht grijs en is niet klikbaar...   Ik kan dus niet kiezen voor 
APN advancedinternet.

 

En omdat mijn KPN SimCard voor een andere MiFi is wil ik een nieuwe Sim Card van Vodavone kopen.
Maar ik weet niet welke en ook niet hoe ik de juiste ASN aan de Sim Card gekoppeld krijg door Vodafone; m.a.w. wie moet ik hiervoor bij Vodafone benaderen?   Door Vodafone moet dus de juiste APN aangezet worden op de Sim Card.

Als dat dan goed is gegaan zou ik een Public-IP@ moeten hebben gekregen.

Pas daarna kan ik verder met DynDNS en  Port Forward. Met die technieken ben je k wel bekend; ben gebruiker van Home Assistant en een NAS, beide met Remote Access.

 

Maar eerst de juiste Vodafone Data Sim Card met de juiste ANS er op.

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Je zegt : "Deze KPN Sim card werkt dus niet zonder aanpassingen. En in de instelling voor APN kan ik niets veranderen.
Dat veld is licht grijs en is niet klikbaar... Ik kan dus niet kiezen voor APN advancedinternet."

Ook niet als je een nieuw profiel aanmaakt? Een huidig profiel veranderen kan waarschijnlijk niet, maar je kunt volgens mij wel een nieuw profiel aanmaken.

 

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

OK, ja, dat heb ik nog niet geprobeerd…  dat ga ik nog even proberen. 

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Vanmorgen nieuwe test.

 

1) Dynamic DNS aanpassen bij no-ip.com met het nieuwe Private IP@ wat ik zojuist van KPN heb gekregen.

Het lukt me niet om de DDNS met no-ip.com te activeren op de TP-Link 4G router:
KPN SimCard in de TP-Link router geeft nu IP@: 100.106.15.82.   (Ook dit is een Private IP@  (zie Wiki Reserves IP addresses)

In no-ip.com dit adress gekoppeld aan de gekozen dns-naam (zie plaatje 1). 

Vervolgens heb ik in de router de ddns settings ingevuld (zelfde credentials als waarmee ik inlog bij no-ip.com!)

maar ik krijg dan: Authentication Failed.

(Ik denk dat dit komt omdat ik geen Public-IP@ heb gekregen, of zie ik dit verkeerd?

 

2) Testen met NAT Forwarding is lastig wanneer ik niet de thermostaat beschikbaar heb (Deze moet aan de ketel aangesloten zijn, anders komt hij niet op het WiFi. En ik ben nu niet ter plaatse.) 
Ik probeer een Raspberry Pi met een webserver op te tuigen, zodat ik hier port 80 kan testen in het lan van de TP-Link router.

Wordt vervolgd...

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Ik denk dat de volgorde niet goed is. Je moet eerst van je provider een public IP adres hebben, anders zal de DDNS niet werken. Hoe moet de naamserver immers jouw modem vinden als hij niet aan publiek IP adres hangt?

Heb je een nieuw profiel kunnen aanmaken met advanced internet? Dan zou ik daarna de andere profielen weggooien. Was bij mij het probleem: het modem bleef vasthouden aan een ander profiel dan ik wilde. Door alle profielen weg te gooien op die ene na, heeft het modem geen keuze meer. Bij mij werkte dat. Wel even een screenshot maken van de instellingen van de profielen die je weggooit. Voor het geval je ze toch weer opnieuw wilt aanmaken.

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Je hebt gelijk. Ik moet eerst een Public-IP@ hebben.
Ik heb vanmorgen een heel goed gesprek gehad met een Vodafone medewerker die precies wist waar het om gaat.

Ik heb nu een prepaid sim card besteld en zodra deze on-line komt zullen zij daar een APN open.vodafone.com op zetten. (wel even bellen met deze medewerker ;-))
Daarna kan ik die APN in de router activeren en zal ik een Public-IP@ moeten hebben. 
De rest, DDNS en Virtual Server instellen, is dan simpel.  

(Ik wilde niet met de KPN Sim Card en de KPN helpdesk aan de slag. Die Sim Card heeft een ander doel en was alleen even om te testen. )
Ben blij verrast hoe goed dit gesprek ging met Vodafone support.

Als de sim card binnen is laat ik nog even weten of alles werkt.

 

@Saud Vooralsnog Heel hartelijk dank voor al je hulp (en geduld met mij 😉 )

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Als je de juiste persoon aan de lijn krijgt, kan het snel gaan. Fijn dat het gaat lukken. Succes en laat het even weten zodra het echt werkt! 👌

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

Heb vanmiddag de SIM Card binnen gekregen. Geactiveerd in m'n telefoon en vervolgens in de router gestopt.
Ik krijg nog steeds een Privte-IP@, maar er zit wel een APN op met live.vodafone.com. 
Maar het WAN IP@ is 10.209.x.y.  (Na uit en aan schakelen krijg ik een IP@: 100.x.y.z.

 

Heb Vodafone gebeld en kreeg een andere dame aan de telefoon, die beweerde dat het helemaal niet kan dat particulieren een Public-IP@ op een SIM Card krijgen. (Gisteren beweerde Wendy nog dat het geen enkel probleem was en dat ik na activeren van de SIM Card moest bellen en dat men het dan zou activeren.)

 

Deze dame wil dat ik een zakelijke SIM Card neem, daar kan het wel mee. Goedkoopste zakelijke SIM Card is Euro. 16,--/mnd.
(toch een heel bedrag voor een muziekvereniging...)

Misschien nog eens een andere dag bellen om te kijken of het toch zou kunnen voor een vereniging...

Saud

Gedreven Liefhebber
  • 26Posts
  • 1Oplossingen
  • 8Likes

Ja, bij live.vodafone.com krijg je alleen een private IP. Voor een publiek IP adres moet je open.vodafone.com hebben. Maar daar moet de juiste persoon bij Vodafone je mee helpen. Bij Wendy lijk je een betere kans te maken als ik het zo lees. Altijd lastig dat je iemand hebt gesproken die helemaal begrijpt wat je bedoelt, die belooft het te zullen regelen. En dan bel je terug, en dat krijg je iemand anders aan de lijn die zegt dat het niet kan. Wat die opmerking over een zakelijk kaartje betreft: dat zou nog wel eens kunnen. Ik heb zelf een Vodafone RED abo vanaf 2017 van 20 euro en het zou kunnen dat een zakelijke variant is (kan dat nergens anders uit afleiden dan dat ik alle prijzen en bedragen altijd excl. BTW zie). Ik heb bij mijn telefoonabo een extra Multi Data Sim kaart genomen voor 5 euro incl. BTW. Voor alles bij elkaar betaal ik 25,82 incl. BTW. Dan heb ik wel extra voordeel omdat ik ook Ziggo klant ben.

Ik keek even naar je bestand "TP-Link Vodafone Cfg Advanced APN". Kun je daar niet zelf een nieuw profiel aanmaken waar je bewust kiest voor de open.vodafone.com APN? Zoals eerder gezegd had ik dat zelf in mijn modem ook gedaan en ik kreeg het maar niet werkend. Mijn modem bleef steeds kiezen voor live.vodafone.com. Toen heb ik op aanraden van de Vodafone medewerker alle profielen uit het modem verwijderd, behalve degene met open.vodafone.com. En toen werkte het ineens nadat ik het modem opnieuw opstartte. Dat kun je nog eens proberen. En anders inderdaad op een andere dag bellen en hopen dat je iemand aan de lijn krijgt die goed met je meedenkt.

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

   Mijn modem bleef steeds kiezen voor live.vodafone.com. Toen heb ik op aanraden van de Vodafone medewerker alle profielen uit   
   het modem verwijderd, behalve degene met open.vodafone.com. En toen werkte het ineens nadat ik het modem opnieuw
   opstartte. Dat kun je nog eens proberen.

Dit ga ik nog eens proberen. En morgen waag ik er nog een belletje aan.

deltabert
topicstarter
Meedenker
  • 14Posts
  • 1Oplossingen
  • 1Likes

@Saud Als ik een eigen profile aanmaak kan ik als APN kiezen voor open.vodafone.nl   Dat is al vast positief!!!
Maar wat moet ik bij d eoverige velden invullen, mn username en password.
Ik neem aan dat Authentication Type: CHAP moet zijn, zoals het oorspronkelijke profile.
Ik geloof niet dat ik een usename en password van Vodafone heb gekregen....

 

EDIT.
Ik zag dat bij het originele 'Vodafone(default:1)' profile de velden usename en password niet waren ingevuld.
Heb een profiel aangemaakt (met APN open.vodafoon.com) maar daarmee kreeg ik nog geen Public-IP@. 

ook als ik de router reboot met het nieuwe profile, krijg ik geen Public-IP@, jammer.  Morgen maar telefonisch proberen.

E-mail notificaties
Aan Uit

Ontvang een update bij nieuwe reacties in dit topic.

Uitgelicht topic